0

RIP(动态路由协议)———小实验

 4 months ago
source link: https://blog.51cto.com/u_15624393/5284207
Go to the source link to view the article. You can view the picture content, updated content and better typesetting reading experience. If the link is broken, please click the button below to view the snapshot at that time.

RIP(动态路由协议)———小实验

原创

阿杰无敌 2022-05-09 17:17:32 ©著作权

文章标签 RIP动态路由协议 文章分类 通信技术 网络/安全 阅读数212

RIP(动态路由协议)———小实验_RIP动态路由协议

实验要求配置RIP,RIP版本为2,关闭RIP的默认自动汇总

拓扑网络规划如下:

e0/0 192.168.12.1 /24

e0/0 192.168.12.2 /24

e0/0 192.168.23.3 /24

loopback0

192.168.1.1 /24

e0/1 192.168.23.2 /24

loopback0

192.168.3.1/24

loopback0  192.168.2.1 /24

IOU1接口配置IP地址和测试接口(loopback)

IOU1(config)#interface ethernet 0/0
IOU1(config-if)#ip address 192.168.12.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface loopback 0
IOU1(config-if)#ip address 192.168.1.1 255.255.255.0
IOU1(config-if)#exit

IOU2接口配置IP地址和测试接口(loopback)

IOU2(config)#interface ethernet 0/0
IOU2(config-if)#ip address 192.168.12.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface loopback 0
IOU2(config-if)#ip address 192.168.2.1 255.255.255.0
IOU2(config-if)#exit
IOU2(config)#interface ethernet 0/1
IOU2(config-if)#ip address 192.168.23.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#ex

IOU3接口配置IP地址和测试接口(loopback)

IOU3(config)#interface ethernet 0/0
IOU3(config-if)#ip address 192.168.23.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface loopback 0
IOU3(config-if)#ip address 192.168.3.1 255.255.255.0
IOU3(config-if)#ex
查看接口是否UP使用show ip interface brief命令

RIP(动态路由协议)———小实验_RIP动态路由协议_02

IOU1上配置动态路由

IOU1(config)#router rip
IOU1(config-router)#network 192.168.12.0
IOU1(config-router)#network 192.168.1.0
IOU1(config-router)#version 2
IOU1(config-router)#no auto-summary
IOU1(config-router)#ex

IOU2上配置动态路由

IOU2(config)#router rip
IOU2(config-router)#network 192.168.12.0
IOU2(config-router)#network 192.168.23.0
IOU2(config-router)#network 192.168.2.0
IOU2(config-router)#version 2
IOU2(config-router)#no auto-summary
IOU2(config-router)#ex

IOU3上配置动态路由

IOU3(config)#router rip
IOU3(config-router)#network 192.168.23.0
IOU3(config-router)#network 192.168.3.0
IOU3(config-router)#version 2
IOU3(config-router)#no auto-summary
IOU3(config-router)#ex
查看动态路由配置是否成功使用show ip route命令

RIP(动态路由协议)———小实验_RIP动态路由协议_03

然后ping一下看看通不通

RIP(动态路由协议)———小实验_RIP动态路由协议_04

RIP(动态路由协议)———小实验_RIP动态路由协议_05

这样就完成了!


About Joyk


Aggregate valuable and interesting links.
Joyk means Joy of geeK